Apache Maven WAR Plugin Version 3.2.1 Released

News - NETCreator - 2018-05-13 13:15:31

The Apache Maven team is pleased to announce the release of the Apache Maven WAR Plugin, version 3.2.1.

The WAR Plugin is responsible for collecting all artifact dependencies, classes and resources of the web application and packaging them into a web application archive.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-war-plugin</artifactId>
  <version>3.2.1</version>
</plugin>

You can download the appropriate sources etc. from the download page.

Important Note:

  • Maven 3.X only
  • JDK 7 minimum requirement

Release Notes – Maven WAR Plugin – Version 3.1.0

Improvement:

Task:

  • MWAR-401 – Upgrade the WAR lifecycle to use the maven-compiler-plugin 3.7.0

Dependency upgrades:

  • MWAR-413 – Upgrade xstream to 1.4.10
  • MWAR-414 – Upgrade mave-surefire/failsafe-plugin 2.21.0
  • MWAR-416 – Upgrade plexus-archiver to 3.6.0

Enjoy,

-The Apache Maven team


Source: Apache
Latest Posts
NETCreator CMS

Search
Free Hosting